
This sheet accompanies TechCamp Online: Mining Data in Excel 2010 for Windows users. This contains step-by-step instructions for the skills we covered in the online training. 
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[bookmark: _Toc213934062]Prep for a Fundraising Appeal 
When approaching a set of data that you’re going to use for a multi-step process like a fundraising appeal, there are a number of steps you should always go through: 
· Set goals
· ID your audience
· Collect data (ongoing)
· Review & clean your data – how clean is it?
· Look at history – make some reports and visualize data to make decisions
· Segment your data
[bookmark: _Toc213934063]Best Practices of Data Collection
· Accurate first and last
· Nickname or name they go by
· Cell and landline, labeled
· Email
· Preferred method of contact
· Home address 
· Any other key info for your work – example: issues interest, reason for giving
Database notes
· A good database would easily be able to make a list of who gave in the past two years.
· We’re not going to cover this, but you do need to get your data into Excel. We’re going to assume you know how to do this. The single thing I’ll say about this is remember to always include contact ID’s (sometimes called a primary key) when exporting from your database. First and last name by themselves aren’t enough to distinguish someone as unique. 
[bookmark: _Toc213934064]Publication 28: Addressing Standards
[bookmark: ep536189]http://pe.usps.com/text/pub28/welcome.htm
[image: ines of address - Recipient, Delivery Address and Last.]
[bookmark: _Toc213934065]Shortcuts in Excel
· Ctrl+a = select all
· Ctrl+s = save
· Ctrl+c = copy
· Ctrl+v = paste
[bookmark: _Toc213934066][bookmark: _GoBack]Excel Glossary
· Cell  – (A1) one square in the grid. This holds one piece of information.
· Column (A, B, C) – vertical line of cells in document
· Row (1, 2, 3) – horizontal line of cells in document. Often called a record when referring to all the related information stored in one row.
· Worksheet or sheet – one single grid of cells/rows/columns. 
· Workbook – the whole Excel document, often containing multiple sheets.
[bookmark: _Toc295302295][bookmark: _Toc213934067]Understanding Clean Data
Data has to be “clean” and accurate to be useful. “Not clean” means that information is missing, out of date, incorrect, or not uniform, e.g. Bklyn vs. Brooklyn. Spreadsheets & databases are not intelligent. The data is only as good as the person’s attention is who enters it. 
[bookmark: _Toc213934068]Format Spreadsheets & Data
[bookmark: _Toc213934069]Resizing 
Columns – move cursor over column labels (A, B, C, etc.) and let it hover on the line between two columns. The cursor changes shape to a plus sign with arrows pointing out horizontally. You can now click down and resize the column by dragging left or right. 
Rows – do the same thing as for columns, but hold the cursor on the line between the row headings (1, 2, 3, etc.) until it changes shape. Click and hold down, moving up or down to resize. 
[bookmark: _Toc213934070]Naming/Renaming Sheets
Double-click on the tab in the lower left-hand corner that says Sheet1. This will allow you to type in a new name. 
[bookmark: _Toc213934071]Saving an Excel Document
Click File the in the upper left-hand corner. Click Save As. Choose where you want to save the file and navigate there. Here, you may choose to save the file as an .xlsx file, which means it’s in a 2007 format or newer. If you will be sharing the document with people who use versions of Excel older than 2007, you may want to choose the .xls (older) format.  
[bookmark: _Toc213934072]Understanding Data Types: Label, Value, Date/Time, Formula
Excel needs to know what type of information/data is in the sheet.  It’s smart so if you tell it what kind of data it’s dealing with, it can make some of your work easier. 
· Labels: alphanumerical, are as they appear, is an entry that is usually used for headings, names, and for identifying columns of data. Labels can contain letters and numbers. 
· Values: numerical, are used for calculations 
· Date/Time: used to automatically format date & time data
· Formulas: calculations/manipulations of numbers (values) 

Always look at your data/information before you apply a calculation/formula. Are you looking at a value, a formula, a label? 
[bookmark: _Toc213934073]Formatting Columns, Column Headings, Cells
Formatting is mostly in the HOME tab. This is similar to Word.  Excel is only smart about some things, so don’t forget – you need to let it know specifically what you want to do with the information. 
Column Headings – Name them according to useful categories of data. You should have only one piece of information in each row, to make it easier to use your data. For example, first name and last name should be in separate columns. 
Bold & Center the Heading Row – Move your mouse over to the 1 at the beginning of the first row, hovering until the cursor is a black horizontal arrow. Click to select the entire row. Now hit Bold, the big B in the Home tab. With the row still selected, click the Center button in the group of commands in the Home tab called Alignment.
[bookmark: _Toc213934074]Format Cells to Match the Data Type
Format Cells: Tell Excel how to treat your data through the Format Cells command. 
Some format types include Number, Currency, Date, Time, Text, and more. The General type is assigned by default to any new data. General treats numbers as numbers and text as text. This seems like a good idea, but it isn’t always. For example, if you’re storing zip codes (which look like numbers), you’ll want to change their Data Type to Special > Zip Code.  
This is because they aren’t actually numbers. Some zips have leading zeroes (01234) and without instructions, Excel will think that’s a number and remove the 0. This is a big problem for keep your data accurate. 
Select column. Right-click on column header. Select Format Cells. Click Special. Choose Zip Code.  
You can alternately go to the Home tab and click Format and at the bottom of the list of commands, choose Format Cells. 
Currency
For the Event Fee column in Sheet2 of the Practice File for Basic Excel, select the column. Right-click, select Format Cells, and click Currency. You have options about how the currency is displayed when it’s negative (it can show up in red, or with a negative sign, etc.) and what currency symbol is used. Click Ok. 
Text
Do the same for the Zip code column. Change to Text. A small green triangle appears to let you know Excel thinks there’s something weird about this. Ignore that – you actually do want that thing that looks like a number to be treated as text!
Date
Change Registration Date to Date format using the same steps. 
[bookmark: _Toc213934075]Adding Borders to your Document
Delineate certain information in your data with a table by adding borders.
Select the cells that you want to add borders too. In the Home tab, in the Font group, select the little box that looks like a window or table. Choose All Borders for a table; choose Bottom Border to create horizontal lines only.
[bookmark: _Toc213934076]Insert Columns & Rows
Go to the header letter or number of the column or row (A or 1). Right-click and select Insert to add a column before the one you’ve selected. Right-click and select Insert to add a row above the one you’ve selected. 
[bookmark: _Toc213934077]Delete
Follow the steps to insert, but select Delete instead.
[bookmark: _Toc213934078]Copy & Paste
Insert a row above row 2. Now select row 3 (which used to be row 2). Right-click and select Copy. Right click on the blank row above it and click Paste.  You can alternately click Insert Copied Cells and you’ll create a new row with all the data in it. 
[bookmark: _Toc213934079]Printing Spreadsheet & Viewing
Click the Button. Select Print Preview to see what your document will look like after printing. 
Change the orientation of your document if your document would fit better on a horizontal orientation (called Landscape) rather than a vertical one (Portrait). 
Click the Page Layout tab. Select Orientation. Click Landscape. 
Change how you’re looking at your document. From the View tab, click Page Layout. You’ll see how your data looks if you print it. 
[bookmark: _Toc213934080]Freeze Panes 
To keep the column headers or row headers in place as you scroll through your data, choose menu item View. Choose Freeze Top Row (or Freeze First Column). Do the same to unfreeze panes. 
[bookmark: _Toc213934081]Filter 
Filtering is a way to look at a subset of your data/information based on a criterion (like all people who gave in 2011, live in Fairfax, or are interested in Worker Rights.  
Enable filtering by going to the worksheet where you want to apply a filter. Go to Data tab. Click on the funnel icon, labeled “Filter”.
Click the arrow on the column you want to filter (City, for example). Click Select All, which is already selected, to deselect all. Scroll down and click Fairfax. You will now have a list of only folks with addresses in Fairfax. 
Alternately, leave all selected but scroll to the bottom to deselect Blanks. Now, only folks with a City will appear.
Apply a custom filter. Choose Most Recent Gift column. Click filter arrow. Choose Number Filter. Select Greater Than and type 100 in box. You’ll be left with everyone whose most recent gift was greater than $100. 
[bookmark: _Toc213934082]Sort
You may also want to organize your records in alphabetical or numerical order – say alphabetically by last name, donation date or amount. 
Sort data by a single column using alpha or numeric criterion. Sort by City, so highlight the City column. Click Data tab, click Sort. By default, the sort will be alphabetical if you are working with text, and numerically ascending if with numbers. Always choose Expand the Selection when prompted.
To sort by more than one column, highlight nothing. In Data tab, click Sort. Choose City in Sort by field to first sort on City. Click Add Level to sort by another column. Now choose Last to sort by Last name. Leave A to Z chosen in both rows. Click Ok. Everyone from Alexandria is clustered together and ordered by last name, and so is everyone from Arlington, and so forth. 
To create a non-alpha or numerical order, change A to Z to Custom List. Then enter the values in the order you want to apply to your list.
Example: For a walk sheet, you would want to do some serious sorting and filtering to create lists for your walker volunteers. You might sort by precinct, then by street name, then by street number. 
[bookmark: _Toc213934083]Text-to-Columns
Use Street Address need to add columns for each part of string that we want to separate out – add at least 4 new columns to be safe (one for each piece of data that will be separated out).

1. Insert 3 columns
2. Highlight range of cells (Street Address) to split
3. Click Data Tab.  Now find Text to Columns, and click.  
4. This will walk you through the text to column split.
5. Select Delimited – this means the text you want to split has some consistent marker at the point that you want to split it.  Our delimiter is a space. Deselect tab, and you’ll be able to preview the way the data will look once you’re done in the space below the options.
6. If you continue through the wizard, you can also choose the data format of the destination cells, or cells that the split data is going to be popped into. Otherwise, click finish.
[bookmark: _Toc213934084]Formulas
A formula can be typed directly into a cell or into the formula bar above. Select the cell, and then click in the formula bar up top. That lets you see the whole formula that you’re typing out.  Type your formulas here for an easier time of it. 
[bookmark: _Toc213934085]Sum
Add all the numbers that are in the same column (in the practice file, find out what the Event Fee total is).  Below the Most Recent Gift Column, type =SUM(O2:O99). The colon “:” means everything between. So O5:O25 indicates everything starting at O2 going through O99, also known as a range.
[bookmark: _Toc213934086]CountIf
“Add up” text instead of values. 
To find how many 2011 donors are interested in Worker Rights, type =CountIf(S2:S99, “Worker Rights”) in an empty cell. 
=COUNTIF(range, criteria) 
[bookmark: _Toc213934087][bookmark: _Toc295302297]Average
Similar to the Sum formula, average just needs a range of cells. 
=AVERAGE(O2:O99)	
[bookmark: _Toc213934088]If Formula
This formula gives you one value if a cell satisfies a certain criteria (Q2 in this case), and another value if it doesn’t (a blank “”). =IF(P2=1, Q2, "")
[bookmark: _Toc213934089]Copy Formula Down the Column
Copy the formula. Put your cursor in the cell below it. Hit Shift+Ctrl+down arrow simultaneously. You should arrive at the end of data in that column. Paste. The formula will be pasted in every cell in the column. 
[bookmark: _Toc213934090]Paste Special
Notice that Value of First Gift column we just created contains formulas.  You can see that by clicking on the first cell – in the cell itself, you see that it reveals the formula that generates that text.  If you want to remove the formulas, you’ll want to keep just the actual values. 
To get values from formulas:
· Insert Column
· Highlight range of cells to copy
· Copy (CTRL+C or right-click and Copy)
· Click in first cell to copy to
· Right click and Paste Special, click Values (rather than formulas)

[bookmark: _Toc295302300][bookmark: _Toc213934091]Creating a Graph/Chart
The key is set-up. Create a column for the labels that will go along the x-axis, or bottom of the chart (in Sample Data, I’ve filled the column with Weeks 1 through 9.) Create a second column with a heading which will become the title of the chart, Weekly Totals During 2011 Appeal. Put in the values for each corresponding week in that column. Add additional columns if appropriate (for example, data from 2010 for the same weeks of the appeal to compare how that one went). 
The set-up is the trickiest part. Once you have the data set up, the chart is a snap. 
Choose Insert from the menu. In the chart section, choose the type of chart you’d like to insert and click. Adjust as necessary by changing the chart type, the data set-up, etc.
[bookmark: _Toc213934092]Link Spreadsheets
Refer to Info in One Sheet in Another Sheet
This allows you to refer to calculations from another sheet on a new sheet. We’ll refer to the 2010 totals sum that we created on the sheet called 2010. Go into a blank sheet. In A1, type Event Total. In A2, type =2010!P39 if P39 is where the total event fee that you summed up lives. You should see the contents of P39 in A2. If P39 changes, A2 will reflect that change.
Link Sheets with a Calculation 
On a blank sheet, we want to get a count of how many donors were interested in workers rights from each year. In a blank cell like B3, type =CountIf(2010!V2:V20, “Workers Rights”). You should get a total count of members in the type column from the Main sheet. (Remember, copying and pasting from Word into Excel may not work, so type out the formula from scratch.)
=COUNTIF(name of sheet!range, criteria)  
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